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Introduction 
Scope of These Materials 
This script covers a series of vignettes that explore most of the new features in Autodesk® Revit® 
Structure 2012 software. You should tailor the presentation to what matters most for your audience.  

Demonstration Goals & Objectives 
This demonstration is intended to introduce existing customers to the benefits that the latest release 
offers. New prospects should be shown the Overview Demonstration.  

Effective Content Use 
Here’s what’s included with these vignettes, and some notes on effective use. 
This kit includes the following components: 
• An instructional video (.avi) for each vignette. These videos are designed to assist you in learning the 

content. 
• Data sets for use with each vignette or set of vignettes. These are available so that you can perform 

the demonstrations live. 
•   Demo instructions with narration (this document).  
 

Software Requirements 
You will need Autodesk Revit Structure 2012 with all recent updates installed.  
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Practical Information 
Script Format 
This script is meant to be a framework of steps and verbiage to use during the demonstration. Feel free to 
use your own style, but take care to use the messaging and language that Autodesk has provided in this 
script during your version of the presentation.  
This script uses simple formatting making it easy for you to learn the demo quickly and present it 
effectively. Here is an example: 

SUBSECTION HEADER 
Describes what happens 
next in the demo. 
 
 
 
 
MARKETING SCRIPT 
Provides a description of 
what will happen and why 
it matters to customers. 
 
 
 
 
DEMO INSTRUCTIONS 
Provides the steps you 
should follow to provide 
the demo. Refer to video 
for complete step by step 
where necessary. 
 

 

Why are some things not spelled out click per click? 
This demonstration assumes that you have a good foundation of Autodesk® Revit® Structure skills. If the 
instructions do not provide you enough information, be sure to watch the included instructional 
video files. Each video goes through every step necessary to perform the demonstration. 

Data Files 
In the Data folder are several subfolders that contain drawings and data that you will reference throughout 
the demonstration. Familiarize yourself with the contents of these folders and be aware that the RVT files 
are already set up to reference other files from this location. 
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Enhance Productivity 
This release introduces several enhancements to existing features that increase the effectiveness of 
Autodesk Revit Structure. The two most important enhancements for structural engineers are enhanced 
analytical model and improved modeling of 3D reinforcements. 
 

Enhanced Analytical Model 
Autodesk Revit Structure 2012 provides some enhancements to help users create and manage the 
structural analytical model such as better visibility and greater control over the analytical model. 
 

Exploring the analytical model as a separate object 
Purpose: The physical model drives construction documentation. Engineers and architects use it for 
coordination purposes such as interference checking. The analytical model contains information that can 
be used in several popular third-party analysis applications for calculations. This new 
feature allows the engineer to work with just the analytical model and also to work better 
with both the analytical and physical models at the same time. 
 

1. Open Enhanced_Analytical_Model.rvt.  
2. As per the movie select a column. 
3. Click the Filter button. 
4. Unselect Analytical Columns option. 
5. Look at the Properties window. 
6. This time select only the analytical model of the column. 
7. Explore the Properties window. 

Parameters associated with the analytical model previously listed in Properties as part of 
the physical element have been moved to Properties analytical elements. Access to these 
properties can be made by selecting the physical or analytical element. When the physical is selected the 
analytical properties can be reached by using the combo box just below the type selector in the 
Properties. The same is true if the analytical is selected. 
 

8. Once again select the analytical model of the column. 
9. Click Highlight Physical button. 
10. Click Disable Analytical button. 
11. Select a physical column 
12. Check the Enable Analytical Model option in Properties window. 

The user can highlight the physical model of an element selecting only analytical one and vice versa.  
Also the user can more easily decide if an element is structural or not. Physical elements that can have 
an analytical model contain the “Enable Analytical Model” parameter, and unchecking this parameter will 
remove the analytical model from the physical element. This property is also accessible when selecting 
an analytical model element. You can remove this element by clicking Disable Analytical in the analytical 
model’s contextual tab. 
Payoff: Access to the analytical model parameters is easier and now the user will spend less time 
creating the analytical model of the structure. 
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Exploring the new control tools of visibility of the analytical 
model  
 
Purpose: Working with the analytical model today is difficult for many engineers 
because when the analytical model work needs to be done the elements fight for 
the user’s attention with the physical model. The user should have the ability to 
quickly display just the analytical model of the structure.  
 

1. Open the Visibility/Graphics Overrides dialog box (use shortcut VG) 
2. Go on the third tab the Analytical Model Categories. 

Control of the visibility of the analytical model has been enhanced by adding a tab to the 
Visibility/Graphics Overrides dialog. Analytical model visibility settings that formerly existed on the Model 
Categories tab have been migrated to the Analytical Model Categories tab. These include boundary 
conditions, structural internal loads, structural load case, and structural loads. 
 

3. Check all analytical model visibility settings. 
4. In the View control bar turn on the Temporarily Display Only 

Analytical Model Categories feature. 
This new tool enables you to quickly temporarily hide and isolate the analytical model. 
 

5. As per the movie, open the Visibility/Graphics Overrides dialog box once 
again and filter some structural objects.  

6. Open the Structural Settings dialog box on the Analytical Model Settings. 
Check the Differentiate ends of linear analytical elements option. 

The user needs to define particular properties or behaviors at the individual ends of 
these structural elements. 
Autodesk Revit Structure was limited in its ability to identify/display the start or end.  
In this release, users can identify ends (start, end) of linear elements to more easily define boundary 
conditions for those elements. It is possible to turn on color coding of analytical model end segments to 
help identify those ends. 
 

7. Change Visual Style from Hidden Line to Shaded. 
Floor, slab and wall analytical models have a surface. Because to this, those 
structural elements can be easier identified in the Analytical Model view. Properties of 
the surface can be set via the Object Styles dialog. 
 
Payoff: Those tools enable you to temporarily and quickly hide and isolate the 
analytical model and display it in a clear way. Improved visualization of the analytical 
model helps you save time while working with structural models. 
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Exploring the new analytical mode 
Purpose: Extend Revit Structure’s capabilities for the analytical model definition to help users create an 
analytical representation of a model according to their individual expectations. Structural engineers often 
create analytical models that may seem illogical or hard to describe by an algorithm when compared to 
the physical model, and the nature of such decisions is very subjective and based on the engineer’s 
experience. There is a need to guarantee a maximal ease of use of creation of an expected analytical 
model and make it highly editable. 
 

1. Change Visual Style from Shaded to Hidden Line.  
2. Go to the Analyze tab.  
3. Click the Analytical Adjust button. 

The analytical adjust feature has been replaced with an Analytical Edit Mode. In this edit mode the user 
can now more directly modify the analytical model elements of beams, braces, columns, and walls, but 
other elements are still adjusted through their analytical properties. Access to the analytical edit mode can 
be made through the repurposed Analytical Adjust button on the Analyze tab of the ribbon. Additional 
access is provided on the contextual tabs of all the analytical elements. 
 

4. Click the Cancel button and exit the analytical mode. 
5. As per the movie select the analytical model of one of a slanted beam.  
6. Click the Analytical Adjust option on the Modify Analytical Beams tab of 

the ribbon 
When the edit mode is activated, node elements will appear at the ends of all beams, 
braces, and columns and all non-analytical elements will be set to half-tone and made unselectable. 
 

7. While you are in the Analytical Mode once again select the same beam. 
8. Look at the ends of the beams. 
9. Press the space bar and notice that the coordinate symbol changes. 

 
When the analytical element is selected the widgets display the element’s local coordinate system. You 
can change between the global and the local coordinate system simply by hitting the spacebar. 
The Analytical Node itself can be selected. When this is done you will get a widget for the node. Moving 
the node will move the ends of all elements that join with the node. To remove a single element from the 
Analytical Node you 1st select the element and then use the widgets that appear at its end to move only 
the end of that element. The same behavior works for multi-selection. If you want to remove 2 elements 
from an Analytical Node, select each element and move the widget. Only the two elements will move and 
be disjoined from the Analytical Node. 
 
 

10. Using a coordinate system, adjust position of the analytical nodes. 
11. As per the movie, use the Align option to connect two nodes. 
 

Beams, braces, and columns can now be adjusted separately at each end. Adjustments include 
projecting the elements to datum planes and the ability to manually drag the element’s nodes. When the 
nodes are selected new transform widgets are provided. The widgets provide a visualization of the 
coordinate systems and allow dragging of the node constrained to that axis. 
 

12.  As per the movie, select the analytical model of a slab. 



Autodesk® Revit® Structure 2012 – What’s New Scripted Demonstration 
 

   
  
 8 

13. Show the measure tools and measure the height of the handrail. 
Change the Projection parameter to Auto-detect. 

Horizontal projection parameters for the floor have been moved from being a 
property of the floor sketch line to being a property of the floor (or foundation 
slab) edge. These parameters are available when the whole slab is selected and will affect all edges. This 
is intended to enable the user to more quickly change all edges to autodetect. 
 
Payoff: This improves Revit Structure's ability to manipulate the analytical model to help solve round-
tripping issues between Revit Structure and structural analysis software. 
 

Reinforcement Enhancements 
Autodesk Revit Structure 2012 provides some new functionalities in 3D reinforcement. Enhancements 
have been made to help users more easily define and visualize concrete reinforcement in Autodesk Revit 
Structure. New methods for managing the definition of reinforcement as well as controlling its placement 
have been added. 
 

Exploring the new modes for placing rebar 
Purpose: Extend Revit Structure’s capabilities for easier modeling of 3D reinforcements. Users needed to 
be able to create completed 3D reinforcements for a structural element using only one section view and 
provide more unique placement positions. 
 

1. Open Enhanced_Reinforcements.rvt.  
2. As per the movie, create a section. 
3. Go to the section view. 
4. Click the Rebar option on the Reinforcement panel. 
5. Choose Perpendicular to Cover mode. 
6. In the Rebar Shape Browser select Rebar Shape:M_T1 
7. As per the movie, define the rebar. 
8. As per the movie, select rebar and define the spacing and number of rebars. 
9. Click the Rebar option on the Reinforcement panel. 
10. Choose Parallel to Work Plane mode. 
11. In the Rebar Shape Browser select Rebar Shape:M_00 
12. As per the movie, define the rebars in section view. 
13. Change the number of rebars to three each. 

There are now three modes for placing planar rebar. Previously, the user had to choose 
between two: Parallel to Work Plane and Perpendicular to Work Plane. Starting in Revit 
Structure 2012, the Perpendicular mode has been divided into two new modes: Perpendicular to Work 
Plane and Parallel to Cover and Perpendicular to Work Plane and Perpendicular to Cover. These three 
modes, combined with the ability to flip and rotate the rebar in eight different orientations by pressing the 
spacebar, provide 24 unique placement positions. 
 
Payoff: It helps the user more quickly and easily define reinforcements and increase the user's 
productivity. 
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Stirrup attachment beyond cover reference and self-intersecting bar 
Purpose: For some markets the definition of rebar cover is the distance between the surface of a main 
rebar and the surface of a concrete host without taking the diameter of a stirrup into consideration. 
 

1. Select just defined stirrups. 
2. Go to the Project Browser and find the rebar family. 
3. Edit the family. 
4. In the Rebar Shape parameters window change Stirrup/Tie Attachment parameter 

from Interior Face of Cover Reference to Exterior Face of Cover Reference.  
5. Load the family into project. 
6. Overwrite the existing version. 
7. As per the movie, change select the reinforcements and change the Visibility States to see 

applied changes. 
Rebar stirrup and tie style families can now be set to snap to the exterior of a cover reference rather than 
the interior which is the current default. A new type parameter may be set in rebar family edit 
mode or sketch mode to select either Interior Face of Cover Reference or Exterior Face of 
Cover Reference. Using this parameter definition of rebars without collision is much easier 
and faster.  
 

8. As per the movie zoom in and rotate in 3D view to see better a single stirrup. 
9. Go to the section view. 
10. Change Detail Level between Fine and Medium to see the difference in presentation of 

stirrups. 
Planar reinforcement is now depicted more accurately in both 2D and 3D views. Intersecting bars overlap 
as they should. The level of detail is maintained with the existing symbolic nature of rebar, so you can 
have real visualization of a self-intersecting bar. 
Payoff: Help users define and visualize concrete reinforcement more easily. 
 

Multi-planar reinforcement 
Purpose: The user or 3rd party developer could only create 2D shapes reinforcement in 
Autodesk Revit Structure. The ability to create 3D shapes reinforcement was missing in 
Autodesk Revit Structure and there was no good workaround. The 3D shapes 
reinforcement is very important and essential for structural business because concrete or precast 
concrete buildings, bridges, tunnels, etc. all require 3D shapes reinforcement. 
 

1. Click the Rebar option on the Reinforcement panel. 
2. Click the Sketch Rebar option. 
3. Select the column. 
4. Click the Multi-planar option. 
5. As per the movie, create rebar sketch. 
6. Click Finish Edit Mode.  
7. Go to the 3D view to see the defined rebar. 
8. Open the Enhanced_Reinforcements_Final.rvt file to explore reinforcement 

of the column. 
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You can model rebar shapes that are bent in more than one plane. In the rebar family editor you can now 
create a copy of the existing shape connected via segments bent out of plane. This enables the creation 
of many of the most common multi-planar shapes. 
Payoff: These new functionalities of reinforcement modeling and visualization move us forward to the 
next stage for detailing and scheduling. 
 

Family Editor 
 

Formula Driven Component Types 
1. Start a new conceptual massing family  
2. Create a box-like form element  
3. Select 3 surfaces and click on Divide Surfaces  
4. Select one of the divided surfaces and create an instance 

parameter (for example, ‘divSurface_1’) using the Label 
widget on the Options Bar 

5. The type of this parameter is ‘Family Type: Divided 
Surface’ 

6. Create an instance parameter for the other two and name 
them ‘mySurface_1’ and ‘mySurface_2’ 

7. Assign value (Pattern or Component) to this parameter 
from the drop-down menu in Family Types dialog 

8. Make a permanent dimension for the length and the width 
of the box 

9. Add labeled dimensions to them 
10. Create additional  ‘Divided Surface’ parameters for the 

other divided surfaces, and apply panel components to 
them 

11. Add a formula to drive divSurface_1 parameter= 
If(Length>200, mySurface_1, mySurface_2) 

12. Change the value of Length.  The corresponding surface 
pattern will change 

Creation of parameters can be driven by conditional formulas and applied to divided surface.  The feature 
can be used in:  pattern families, adaptive component templates, conceptual massing family, and all other 
Revit families 
 

Visualization Enhancements 
 
Visualization enhancements present you with more flexible visual style combinations, helping to add 
value to visualization techniques and improve the interactive experience. 
 

Graphic Display Options Dialog 
1. Open File:  Revit_Demo_BIMWorkflow.rvt  
2. In the View Control bar, go to the Graphic Display Options dialog 
3. Model Surfaces can be adjusted through the dialog 
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4. Show Edges is on by default 
5. You can turn on Shadows, Lighting 
6. You can Save as View Template from the Graphics Display Options dialog 

The Graphics Display Options dialog has been enhanced to a more componentized format that more 
closely resembles the Rendering dialog’s structure.   
 

View Styles 
1. Open File:  Revit_Demo_BIMWorkflow.rvt 
2. You can either create a 3D view or Open View:  *3D_Visualization 

to start 
3. In the View Control bar, change the view style to Realistic mode 
4. Realistic views now have Edges on by default 

You now have more control and flexibility in defining how you want to view your 
views 
 

5. In the View Control bar, go to the Graphic Display Options dialog 
6. Change the view style to ‘Hidden Line’ 
7. Under Shadows, check ‘Show Ambient Shadows’ 
8. Click Apply to see changes 

Ambient Occlusion is now available with Hidden Line mode, giving the view a 

soft shadow. 
 

9. Change the view style to ‘Consistent Colors’ 
10. Under Shadows, check ‘Show Ambient Shadows’ 
11. Click Apply to see changes 

Ambient Occlusion is now available with Consistent Colors mode 
 
 

Selection Improvements 
1. Open File:  Revit_Demo_BIMWorkflow.rvt  
2. Select a wall or roof in the model 
3. Semi-Transparency is enabled during selection 

Highlight and selection Colors have been improved.  Transparency and 
Solid Fill have been enabled on selection.   
 
 

4. Go to Application Menu, click Options 
5. Go to Graphics tab, under Colors 
6. You can disable Semi-transparent by unchecking the box 

You can enable/disable use of the semi-transparent effect during 
selection. 
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7. Go to Floor Plans: 1st Floor Clean 
8. Select walls, doors, etc.,  to demonstrate the new visual style of the temporary dimensions. 

A new visual style for temporary dimensions has been enabled.   

Materials Library 
 

Paint Tool Improvements 
1. Open File:  Revit_Demo_BIMWorkflow.rvt 
2. Open View:  *3D_Paint Tool Enhancement to start 
3. Go to Modify tab, and select Paint Tool 
4. Select a material and paint on to the model, you can 

see your changes without closing the Materials 
dialog 

5. Close the dialog 
When the Paint tool is selected, it opens the Materials dialog, 
you can now visually preview materials and access material 
properties in order to modify a material.  Point out that Paint Tool is now available in perspective views, 
and you can also select the surface of the element instead of the edge. 
 
 

6. Go to Modify tab, select the Remove Paint tool from the pull down menu 
where the Paint tool is located 

7. Select the material that you just paint to remove the paint (NOTE:  Remove 
Paint tool will not highlight elements if no materials have been modified). 

There is a new Remove Paint tool to use instead of painting it <By Category> when you 
want to remove the ‘paint’. 
 
 

Material Scheduling 
1. Go to View tab, under Create panel 
2. Select Schedules -> Material  Takeoff 
3. Select <Multi-Category>, Click OK 
4. Under Fields tab, select ‘Material: Name’, ‘Material: 

As Painted’, ‘Material: Area’ (or other fields), and 
Add to Scheduled Fields (in order) 

5. If you want to show only the materials that have 
been painted, you can go to the Filter tab in the 
schedule and isolate painted surfaces only 

You can identify materials that are applied to faces by the paint tool.  You can identify the quantities of 
materials used as Paint in Material Takeoff 
 

Create Property Sets 
1. Go to Manage Tab, under Settings panel 
2. Go to Additional Settings, Property Set Libraries 
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3. Select ‘Wood – Dimensional lumber’ , right-click and duplicate 
4. Rename:  *Wood Stud 
5. Select another image in the Appearance tab 
6. Click OK 
7. Go to the Materials button under Settings panel 
8. Select ‘Wood – Dimensional Lumber’ from the Materials list and duplicate 
9. Rename: *Wood Stud – 6” 
10. Go to the Appearance tab 
11. Under Properties, select By Property Set 
12. When Property Sets dialog asks if you would like to ‘Create a new property set’ or ‘Select an 

existing property set’ 
13. Click ‘Select an existing property set’.  You will notice that the it will direct you to the 

Appearance Property Sets tab, choose ‘Wood Stud’ 
14. Close the dialog 

It is more efficient to use property sets that can be referenced by multiple materials than editing 
appearance properties for each individual material.  When multiple Autodesk Revit Structure materials 
can reference the same property set, edits to the property set will propagate to all of the materials. 
 

Managing Materials Library 
1. Go to Manage tab, under Settings panel  
2. Select Additional Settings -> Property Set Libraries 
3. In the Materials dialog, click Manage -> Open Existing 

Library 
4. In the Select File dialog, browse to the Materials Library 

Example.adsklib file and click Open  
You can browse for a library that has been previously created.  User 
libraries allow you to share property sets. 
 
 

5. Click Manage -> Remove Library (NOTE: You cannot recover a library after it has 
been removed.  Removing a library does not place it in the recycle bin.  It is 
immediately removed and cannot be restored). 

You can remove a Material Library that you no longer need. 
 

Locking and Tagging 3D Views 
1. Open File:  Revit_Demo_BIMWorkflow.rvt 
2. Open 3D Views: *3D_Demo_Tagging 
3. In the View Control bar, there is a new button that 

controls locking of 3D views. 
4. Select Save Orientation and Lock View (NOTE:  If 

orientation is not locked and you are trying to tags 
or keynotes view, you will get a warning dialog 
prompt ‘The orientation of the 3D view must be 
locked before you can go to tags or keynotes) 

5. Go to Annotate tab on the ribbon 
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6. Tag windows, add keynotes, and text to the view 
You can now lock a 3D view and tag elements in the view.  Tags can only be placed in 3D views that 
have been locked.  Save Orientation and Lock View locks the view at the current orientation.  Orbiting is 
disabled. 

7. In the View Control bar 
8. Click on ‘Restore Orientation and Lock View’ 

An unlocked, re-oriented view can be restored to its previous locked orientation and tags and keynotes, 
placed at the original orientation, will return 
 
 

9. In the View Control bar 
10. Click on ‘Unlock View’ 

You can unlock the current orientation so that you can navigate and orbit the view.  When the view is 
unlocked, any tags and keynotes placed in the view will disappear. 
 
 

Type Selector Improvements 
1. Open file:  Revit_Demo_BIMWorkflow.rvt 
2. Select a floor from the model, and click on Edit 

Boundary 
3. Go to the Type Selector  
4. Change floor type to ‘Floor: Wood Deck’ 
5. Click Finish Edit Mode 

Type Selector is now available during Sketch mode enabling 
you to change the family type. 
 
 

6. Right-click on the Type Selector in the Properties 
palette 

7. Select Add to Ribbon Modify Tab 
8. Go to Modify tab on the ribbon to see the Type 

Selector 
You can add the Type Selector to the Modify tab on the ribbon. 
 
 

9. Go to Modify tab on the ribbon   
10. Right-click on the Type Selector and select 

Remove from Ribbon Modify Tab 
You can remove the Type Selector from the Modify tab. 
 

Keyboard Shortcut Improvements 
1. Open File:  Revit_Demo_BIMWorkflow.rvt 
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2. Open the Keyboard Shortcuts dialog (either via the View tab on the ribbon or via the Options 
button in the Application Menu) 

3. Click on Command category to sort commands alphabetically 
4. Scroll down to the Zoom commands and assign a single key (Z) for Zoom in Region 
5. Close the dialog 
6. Press ‘Z’ 
7. The status bar shows ‘Shortcut: (Z) Zoom In Region (Navigation bar) 
8. Press the right arrow key to cycle through next options 

The Keyboard Shortcuts dialog provides a quick and easy way to assign or remove shortcuts to your 
tools, improvements have been made on single key will be first in priority. 
 
 

9. Assign one of the commands to have the same 
shortcut keys as another.  

10. A duplication dialog appeared.  
11. Click OK 

Duplication dialog will be prompt when keyboard shortcut has 
been duplicated. 
 
 

12. Select Export button in the Keyboard Shortcuts 
dialog to export all commands.  

13. Close the dialog 
Keyboard shortcuts can export all commands, not just the ones with assignments. 

Starting View 
1. Open file:  Revit_Demo_BIMWorkflow.rvt 
2. Go to Manage tab on the ribbon 
3. Select Starting View under Manage Project panel.  
4. Select ‘Drafting View: Open and Close View’ from 

the pull down menu 
5. Click OK 
6. Close the Revit file 
7. Reopen Revit_Demo_BIMWorkflow.rvt to demonstrate Revit open the view that has been 

set by default 
Starting View allows you to dictate which view Autodesk Revit Structure software should open by default.  
By setting Starting View to a view that contains only some text, it helps reduce long opening times large 
files. 
 
 

Family Import/Export Enhancements 
 

Save All Loaded Families 
1. Open file:  Revit_Demo_BIMWorkflow.rvt  
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2. Go to Application Menu 
3. Go to Save As -> Library -> Family 
4. Choose location to save the families 
5. Select <All Families> in the Family to Save option 
6. Click Save 

Save All Loaded Families command enables you to export all families with a single command after a 
project is done, so you can better organize and increase your company’s loaded family resources for you 
and your colleagues to use on the next project. 
 

Export Family Types 
1. Open file:  Revit_Demo_Desk.rfa 
2. Go to Application Menu 
3. Click on Export -> Family Types 
4. Choose a location 
5. Click Save 

You can export types from a family to a TXT file (Type Catalog).  
 

Dimension Enhancements 
 
Enhancements have been made to the Dimension tool.  You now can customize equality text.  The EQ 
text can be overridden to achieve a customized result for individual dimension segments.  New dimension 
leader and text is also available that allows for more customization. 

Customizable Dimension Equality Text 
1. Open File:  Revit_Demo_BIMWorkflow.rvt 
2. Open View: Floor Plans: 1st Floor_Dims 
3. Zoom into area around Room 146 – Workroom 

(You should see a dimension string with EQ) 
4. In the Equality Display parameter under instance 

parameter, change ‘Equality Text’ to ‘Value’;  
instead of text, it will display actual value 

5. Select individual value text to override 
6. In the Text fields, Below field 
7. Type ‘V.I.F.’ or other value   (NOTE:  The 

Dimension Text override will always take 
precedence over the global type equality text 
setting or value) 

8. Close the dialog 
When continuous dimensions are set with an equality 
constraint, an instance parameter is added to the dimension 
parameter, called Equality Display, and the dimension text is 
overridden with EQ. 
 
 

9. Select an EQ dimension string  
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10. Go to Type Properties and Duplicate 
11. Under ‘Other’ parameter -> Equality Text 
12. Change to ‘EQUAL’ or other value 
13. Click OK  

There is a new Type Parameter for dimension types called Equality Text.  If all of the dimensions are 
using the same type, you can easily set a text that will appear in the case of equal dimensions, and it will 
not be necessary to edit the text for each chain. 
 

Enhancement to Dimension Leaders 
1. Select a dimension (one with Dimension Leader showing) 
2. Go to Edit Type Properties and Duplicate 
3. In the Name dialog, select Name: Line Leader with Shoulder, Inline 
4. Under Graphics Parameter, for Leader Type, select Line 
5. Under Shoulder Length, put in 1/4” 
6. Under Text Parameter, for Text Location, select Inline 
7. Close out the dialog 
8. Test the other different types of new Dimension Leaders 

combinations including: Line Leader, Inline; Line Leader, Above; 
Line Leader with Shoulder, Above 

A line leader is available to complement the existing arc leader as you drag the dimension text off the 
dimension line and out beyond one of the witness lines. 
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BIM Workflow 
Construction modeling, point clouds, and interoperability enhancements enable users to 
update workflows to help increase productivity. 

Construction Modeling 
New modeling tools help you derive better construction insight by coordinating the design 
model and construction model within one single file. Create Parts/Divide Model tools 
provide a method for dividing Revit geometry into smaller parts for the purpose of creating 
more accurate schedules, quantity takeoffs, visualizations, and exports.  
There is also a new element in the software called an “Assembly”.  An assembly is a collection of one or 
more model elements, and is able to detect identical assemblies in the model. For each assembly in a 
model, the user is able to create views of that assembly and place these views on sheets dedicated to 
that assembly. 

Assemblies 
Purpose: To provide intelligence in Autodesk Revit Structure about the concept of parent-childs data 
structure when selecting several model elements and designating them as an “Assembly” that can be 
tagged, scheduled, isolated, and detailed in shop drawings. 
One of the possible uses of Assemblies is for example a precast column containing 
corbels, reinforcements, openings and mounting parts. Such column is prefabricated 
and pre-assembled as a whole in the factory and then will be shipped on the site for 
construction. 
 

1. Open Assembly.rvt. 
2. As per the movie, select the column with corbels using selection window. 
3. Use Filter and unselect Analytical Columns (only structural column, 

reinforcements and generic models should left). 
4. Click the Create Assembly command in the Create panel on the Modify tab. 
5. Change Naming Category (Structural Columns).  
6. Click OK in the New Assembly dialog box to accept the assembly name (Structural Columns 

001) and create it. 
The assembly feature was designed with precast workflows in mind, where users need to 
track and schedule a collection of elements as a single element. For example, you can track 
a precast column made of multiple families including rebar, mounting hardware, and 
corbels. 
 

7. Select the second column with corbels and reinforcements as previously. But 
this time select only one corbel. 

8. Click the Create Assembly command in the Create panel on the Modify tab. 
9. Change Naming Category (Structural Columns) and click OK in the New Assembly 

dialog box. 
10. Select just created assembly (Structural Columns 002) and using the Add/Remove 

feature located on the Assembly panel add the second corbel to the existing assembly.  
11. As per the movie, create assemblies from the next two columns. 

Assemblies will also detect identical geometric configurations, and auto-assign names based on matching 
criteria. For example, if a precast column assembly has same configuration as another column assembly 
in the model, they will be given the same name. 
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12. In the Project Browser find created Structural Columns 001 assembly. 
13. Click the right mouse button on it and select Create Assembly Views. 
14. In the Create Assembly Views dialog box define a Scale 1:20.  
15. As per the movie, create an additional section. 
16. As per the movie, lay out assembly views on the sheet. 

After creating an assembly, you can also generate assembly views. Autodesk Revit Structure generates a 
set of views dedicated to such assembly by isolating it from the main model. All annotations and views 
(for example, sections) created inside assembly views won’t appear 
nor interfere with the regular views of the main model. 
 
Payoff: Assemblies help support the creation of shop drawings for 
prefabricated building assemblies such as precast walls, columns, 
beams, and floors. 
 
 
 
 
 

Create Parts/Divide Model 
1. Open File:  Revit_Demo_BIMWorkflow.rvt  
2. Open View:  Floor Plans: 1st FLOOR_FINISH PLAN  

(We will divide the floor up in Room 112, 146, and 
147) 

3. Select the floor 
4. In the Modify|Walls contextual tab 
5. Under the Create panel, select Parts  (NOTE:  The 

original will be hidden in the active view, and the 
part made visible) 

6. Select the Part 
7. Go to the Modify|Parts contextual tab, under the 

Part panel 
8. Select Divide Parts 
9. Use the Line tool under the Draw panel and draw 

around the vestibule area 
10. Click Finish Edit Mode 
11. Select the vestibule ‘part’ of the floor 
12. Go to the Properties palette and uncheck Material 

By Original 
13. In the Properties palette, Material is now an active 

parameter 
14. In the Materials dialog, under Settings panel 
15. Select *Interior Floor – Walk Off Mat 
16. Click OK 

The new Create Parts/Divide Model tool provides a method for dividing Revit Structure geometry into 
smaller parts for the purpose of creating more accurate schedules, quantity takeoffs, visualizations, and 
exports.  It provides visibility controls and helps to maintain a persistent design intent model. 
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Enhancements to Creation of Surface Sub-region 
on Non-planar Surfaces 

1. Open File:  Revit_Demo_NonPlanar.rfa  
2. Click on Split Face tool  
3. Start drawing on a non-planar surface to create a sub-region 
4. Select Paint tool and paint one of the surface materials - glass 

Creation of surface sub-regions on non-planar surfaces in Conceptual Massing now enabled. 

 

DWG Fidelity 
 
DWG export files – now gain better visual and data fidelity of exported 2D views to DWG.  Redesign the 
DWG Export interface for a smoother user workflow, taking into account new options for export. 
 

DWG Export Dialog 
1. Open File:  Revit_Demo_BIMWorkflow.rvt  
2. Go to Application Menu, and select Export -> CAD 

Formats -> DWG Files 

3. In the DWG export dialog, click the  
4. Under the Modify DWG/DXF Export Setup dialog, 

the dialog displays a series of tabs.  Click through 
the tab to demonstrate the new layout 

The DWG and DXF™ Export user interface has been updated to 
make it easier to export Revit files to DWG/DXF format using a 
predefined set of export settings. 
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Collaboration and Performance 
Collaboration and performance is another major area of focus in making the experience of working on 
large projects and in large teams a more integrated and smoother process. 
 

Worksharing Enhancements 
 
With the Autodesk Revit Structure 2012 release, Revit Structure helps to increase efficiency using 
worksharing.  The new worksharing enhancements help you better understand and collaborate on shared 
models across the project team.  Gain more visibility into element ownership and status to better manage 
team workflows. 
 

Workset Visibility in View Templates 
1. Open File:  Revit_Demo_Worksharing.rvt 
2. Open View:  *3D_Worksharing View to demonstrate 
3. Go to View tab, under Graphics panel, click on View 

Templates -> View Templates Settings 
4. You should be able to see V/G Overrides Worksets 

category (NOTE:  The new settings only appear 
when worksets are enabled in the project) 

5. Close the dialog 
Workset visibility can now managed via view templates.  It is 
available in the standard View Templates dialog 
 

Worksharing Visualization 
1. Go to the View Control Bar 
2. Click on Worksharing Display icon 
3. Go through the different types of worksharing visualization display settings 

There are now new display modes enabling you to visualize.  The new 
commands are available on the View Control bar (NOTE:  The 
worksharing display icon will only appear when worksharing is 
enabled in the project). 
 
 

4. In the View Control bar, select Worksharing Display 
Settings  

5. Go to the Worksets tab, and change the color of the 
worksets 

6. Close the dialog to see changes in the model 
You can customize the Worksharing Display Settings options. 
 
 

7. Go to Application Menu, and select Options  
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8. Under General tab, under Worksharing Update Frequency, you can change the update 
frequency 

9. Close the dialog 
You can control the update frequency in the options dialog. 
 

Disable Worksharing Command 
1. Open File:  Revit_Demo_Worksharing.rvt 

(NOTE:  If you have the file open from previous 
exercise, you will need to exit the file first)  

2. Select Detach from Central as you are opening the 
file 

3. You will see a dialog giving you two options, 
Detach and preserve worksets OR Detach and 
discard worksets.  (Note:  If you select Detach and 
discard worksets, all worksets will be removed 
permanently from the project, including workset 
definitions and visibility settings) 

4. Select Detach and discard worksets to demonstrate all worksets are removed permanently 
from the project. 

Disable Worksharing command is now available on opening a worksharing model 
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Conclusion 
Autodesk Revit Structure 2012 software provides design and 
documentation productivity specifically for structural engineers and 
designers, giving you more tools to automate drafting tasks and 
helping you create structural models and documentation more quickly. 
The new and enhanced design and drafting functionality in the 2012 
release will help you gain immediate productivity and smoother 
collaboration within a software environment you already know. 
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